Changes between Version 2 and Version 3 of UpdateCorePkgsNov2008


Ignore:
Timestamp:
11/24/2008 12:08:17 PM (11 years ago)
Author:
RayPlante
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • UpdateCorePkgsNov2008

    v2 v3  
    2424setup -v lsst 
    2525 
    26 lsstpkg install base        # reinstall base 
     26lsstpkg install -C base        # reinstall base 
    2727 
    2828# now update the rest of the packages 
     
    4141}}} 
    4242 
    43 Here's what your session should look like: 
     43  '''Note:'''::  Depending on the state of your system, `scons 3.2` will be installed either when you reinstall `base` or when you update `lsst`.  In either case, when you finish, you should make sure that both `scons` and `sconsUtils` have version 3.2 declared as "Current": 
     44{{{ 
     45% eups list scons 
     46   1.20       
     47   3.2          Current Setup 
     48% eups list sconsUtils 
     49   1.20       
     50   3.2          Current Setup 
     51}}} 
     52   If either the version 3.2 is not listed or does not have the "Current" flag next to it, run "eups declare" on the errant package: 
     53{{{ 
     54eups declare -c sconsUtils 3.2 -r $LSST_PKGS/sconsUtils/3.2 
     55eups declare -c scons 3.2 -r $LSST_PKGS/sconsUtils/3.2 
     56}}} 
     57 
     58Here's what your session should look like (assuming `scons` gets updated with the `lsst` package): 
    4459 
    4560{{{