wiki:TCTSubversionUpgrade1.6
Last modified 9 years ago Last modified on 04/13/2010 09:45:49 AM

Proposal to Upgrade to Subversion 1.6

Following extracted from email from Robert Lupton on 12 April 2010:

SVN 1.5 introduced merging between trunk and branches, but the initial implementation has problems with so-called "tree conflicts" (http://svnbook.red-bean.com/nightly/en/svn.tour.treeconflicts.html). The svn 1.6 release has significantly improved the situation, and I believe that we should switch to it.

I know that e.g. KT was having problems with merge --reintegrate to the trunk, +and I think it likely that this was at least part of the problem.

This requires updating the svn server, explicitly updating the repository format, and switching to svn 1.6 clients everywhere.

1.6.9 is available for os/x from macports. For linux boxes the web's a little unclear what's involved, but apparently at worst there's a package from RPMForge that works on centOS boxes.