Ticket #807 (closed defect: worksforme)

Opened 10 years ago

Last modified 10 years ago

Out of memory error in daf_persistence

Reported by: fpierfed Owned by: ktl
Priority: normal Milestone:
Component: daf_persistence Keywords:
Cc: Blocked By:
Blocking: Project: LSST
Version Number:
How to repeat:

not applicable

Description

#!/usr/bin/env python
import lsst.daf.persistence as persistence

db = persistence.DbStorage()
db.setPersistLocation(persistence.LogicalLocation('mysql://localhost:3306/mops_onelunation'))
db.setTableForQuery('MovingObject')
db.outColumn('mopsStatus')
db.setQueryWhere('movingObjectId < 10')
db.query()

while(db.next()):
    print(db.getColumnByPosString(0))
db.finishQuery()

produces an out of memory error:

dhcp152-104> ./test.py        
Python(90697) malloc: *** mmap(size=3221229568) failed (error code=12)
*** error: can't allocate region
*** set a breakpoint in malloc_error_break to debug
Traceback (most recent call last):
  File "./test.py", line 15, in <module>
    print(db.getColumnByPosString(0))
  File "/usr/local/lsst_dev/DarwinX86/daf_persistence/3.3.7/python/lsst/daf/persistence/persistenceLib.py", line 1246, in getColumnByPosString
    return _persistenceLib.DbStorage_getColumnByPosString(*args)
Exception: St9bad_alloc

The culprit seems to be getColumnByPosString(). Any other type cast seems to work.

Change History

comment:1 Changed 10 years ago by ktl

  • Status changed from new to assigned
  • Summary changed from ut of memory error in daf_persistence to Out of memory error in daf_persistence

comment:2 Changed 10 years ago by ktl

  • Status changed from assigned to needinfo
  • Owner changed from ktl to fpierfed

I need to have access to the schema and data that you are actually using. This is apparently not lsst10, since that has no data in its MovingObject table in the mops_onelunation database.

comment:3 Changed 10 years ago by fpierfed

Sorry, now it should be OK (on lsst10). Just FYI these are the packages I use:

activemqcpp           2.2.6+1           Current Setup
afw                   3.3.15            Current Setup
apr                   1.3.3             Current Setup
auton                 unknown           Current Setup
base                  3.1               Current Setup
boost                 1.37.0            Current Setup
cfitsio               3006.2            Current Setup
ctrl_events           3.6               Current Setup
daf_base              3.2.8             Current Setup
daf_data              3.2.3             Current Setup
daf_persistence       3.3.7             Current Setup
daymops               unknown+svn9763   Current Setup
doxygen               1.5.7.1           Current Setup
eigen                 2.0.0             Current Setup
eups                  LOCAL:/usr/local/lsst_dev/eups/1.1.1      Setup
gsl                   1.8               Current Setup
lsst                  1.0               Current Setup
lssteups              1.0               Current Setup
minuit                1.7.9             Current Setup
mpich2                1.0.5p4           Current Setup
mysqlclient           5.0.45+1          Current Setup
numpy                 1.2.1             Current Setup
pex_exceptions        3.2.2             Current Setup
pex_harness           3.3.2             Current Setup
pex_logging           3.3.4             Current Setup
pex_policy            3.3.5             Current Setup
python                2.5.2             Current Setup
scons                 3.3               Current Setup
sconsDistrib          0.98.5            Current Setup
sconsUtils            3.3               Current Setup
security              3.2.2             Current Setup
swig                  1.3.36+2          Current Setup
tcltk                 8.5a4             Current Setup
utils                 3.4.3             Current Setup
wcslib                4.2+3             Current Setup
xpa                   2.1.7b2           Current Setup

comment:4 Changed 10 years ago by ktl

Hmm. Works for me using lsst10 with the test script given and the package versions given. This is running on my machine (Linux32) and lsst7 (Linux64).

comment:5 Changed 10 years ago by fpierfed

  • Status changed from needinfo to assigned
  • Owner changed from fpierfed to ktl

Ummm... cannot reproduce it any more. Shall we just close it?

comment:6 Changed 10 years ago by ktl

  • Status changed from assigned to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.