Ticket #783 (closed defect: fixed)

Opened 10 years ago

Last modified 7 years ago

WCS determination fails with cfhttemplate indexes

Reported by: RayPlante Owned by: fergal
Priority: critical Milestone:
Component: meas_astrom Keywords:
Cc: rhl, ktl Blocked By:
Blocking: Project: LSST
Version Number:
How to repeat:
$ cd /lsst/DC3root/ticketFiles/783
$ python fail.py

Note that reproducing this requires access to the mysql database on lsst10, including authorization credentials in ~/.lsst/db-auth.paf.

Description

WCS determination is failing on all visits when the cfhttemplate version of astrometry_net_data is setup. In particular, visit 704893, exposure 0, CCD 0.

Relevant packages:

afw                   3.3.15    	Current Setup
astrometry_net        0.25      	Current Setup
astrometry_net_data   cfhttemplate	Current Setup
ctrl_dc3pipe          3.3.1     	Current Setup
meas_astrom           3.0.6     	Current Setup
meas_pipeline         3.0.6     	Current Setup

Attachments

v704893.ps (27.3 KB) - added by fergal 10 years ago.
Plot of chip positions of sources in image used as example in this bug.

Change History

comment:1 Changed 10 years ago by fergal

  • Status changed from new to assigned

Changed 10 years ago by fergal

Plot of chip positions of sources in image used as example in this bug.

comment:2 Changed 10 years ago by fergal

There's seems to be a problem with the source detection on the example input image. Looking at the chip positions of the sources, there is a vertical line of detections at x=1285. astrometry.net will get confused by such a feature because it will assume that these are real objects. I've attached a plot (v704893.ps) to illustrate the problem

Unfortunately, removing these sources does not fix this bug, and I'm still looking for other problems.

comment:3 Changed 10 years ago by ktl

The line of sources has flags associated with it (flagForDetection == 448 or 449) that causes it to be filtered out by lines 114-115 of meas_pipeline's WcsDeterminationStage.py, so these sources are never passed to astrometry.net.

comment:4 Changed 10 years ago by fergal

The problem seems to be in the index files I've created for the template fields. I've created new ones, and the fail.py example now passes. Let me know if other fields fail.

I'm leaving the bug open because this is only a temporary fix, and I need to work on a more general solution, but I should have done enough to get the pipeline up and running again.

comment:5 Changed 10 years ago by fergal

  • Status changed from assigned to closed
  • Resolution set to fixed

This ticket got forgotten in the hecticness of DC3a. The templates based on the CFHT fields seem to be working well, so I'm closing this bug out.

comment:6 Changed 7 years ago by robyn

  • Milestone DC3a Completed deleted

Milestone DC3a Completed deleted

Note: See TracTickets for help on using tickets.