Ticket #782 (closed defect: fixed)

Opened 10 years ago

Last modified 7 years ago

PSF determination fails in rare cases

Reported by: RayPlante Owned by: rhl
Priority: critical Milestone:
Component: meas_algorithms Keywords:
Cc: ktl Blocked By:
Blocking: Project: LSST
Version Number:
How to repeat:
$ cd /lsst/DC3root/ticketFiles/782
$ python fail.py

Description

Visit 704894, exposure 0, CCD 0, amplifier 1 produces the following during stage 17 (PSF determination):

  File "/lsst/DC3/stacks/gcc433/24apr/Linux64/meas_pipeline/3.0.6/python/lsst/meas/pipeline/PsfDeterminationStage.py", line 46, in process
    psf, cellSet = self._impl(exposure, sourceList, sdqaRatings)
  File "/lsst/DC3/stacks/gcc433/24apr/Linux64/meas_pipeline/3.0.6/python/lsst/meas/pipeline/PsfDeterminationStage.py", line 57, in _impl
    return Psf.getPsf(exposure, sourceList, self._policy, sdqaRatings)
  File "/lsst/DC3/stacks/gcc433/24apr/Linux64/meas_algorithms/3.0.7/python/lsst/meas/algorithms/Psf.py", line 250, in getPsf
    kernelSize, nStarPerCell)
  File "/lsst/DC3/stacks/gcc433/24apr/Linux64/meas_algorithms/3.0.7/python/lsst/meas/algorithms/algorithmsLib.py", line 906, in createKernelFromPsfCandidates
    return _algorithmsLib.createKernelFromPsfCandidates(*args)
lsst.pex.exceptions.exceptionsLib.LsstCppException: 0: lsst::pex::exceptions::LengthErrorException thrown at src/image/ImagePca.cc:106 in void lsst::afw::image::ImagePca<ImageT>::analyze() [with ImageT = lsst::afw::image::Image<float>]
0: Message: Please provide at least one Image for me to analyze

Relevant packages:

afw                   3.3.15    	Current Setup
ctrl_dc3pipe          3.3.1     	Current Setup
ip_isr                3.3.8     	Current Setup
meas_algorithms       3.0.7     	Current Setup
meas_astrom           3.0.6     	Current Setup
meas_pipeline         3.0.6     	Current Setup

Change History

comment:1 Changed 10 years ago by ktl

  • How to repeat modified (diff)
  • Summary changed from PSf determination fails in rare cases to PSF determination fails in rare cases

comment:2 Changed 10 years ago by rhl

  • Status changed from new to assigned

The how-to-repeat works like a charm.

The problem is that the seeing's too uniform in this field, so all the candidate stars fall in the same bin in the seeing-distribution histogram; stay tuned for a resolution.

comment:3 Changed 10 years ago by rhl

  • Status changed from assigned to closed
  • Resolution set to fixed
  • reviewstatus changed from notReady to selfReviewed

The solution was to make the moments of a single pixel (when sum != 0 but sumxx == 0) equal to 1/12, the variance of a uniform distribution in [0,1]. This is sufficient to allow the PSF code to find PSF candidates and proceed merrily

Fixed in r9523

comment:4 Changed 7 years ago by robyn

  • Milestone DC3a Completed deleted

Milestone DC3a Completed deleted

Note: See TracTickets for help on using tickets.