Ticket #776 (closed defect: suspended)

Opened 10 years ago

Last modified 7 years ago

diffim: apparently passing empty array to numpy

Reported by: RayPlante Owned by: rhl
Priority: normal Milestone:
Component: ip_diffim Keywords:
Cc: dubcovsky, ktl Blocked By:
Blocking: Project: LSST
Version Number: ip_diffim 3.3.8
How to repeat:

At NCSA:

cd /lsst/DC3root/ticketFiles/776
python
>>> import fail

Description

Occasionally the IPSD pipeline fails in stage 34 with the following exception:

  File "/lsst/DC3/stacks/gcc412/24apr/Linux64/ip_diffim/3.3.8/python/lsst/ip/dif
fim/diffimTools.py", line 274, in runPca
    U,s,Vh = numpy.linalg.svd( M, full_matrices=0 )
  File "/lsst/DC3/stacks/gcc412/24apr/Linux64/external/numpy/1.2.1/lib/python/nu
mpy/linalg/linalg.py", line 986, in svd
    _assertNonEmpty(a)
  File "/lsst/DC3/stacks/gcc412/24apr/Linux64/external/numpy/1.2.1/lib/python/nu
mpy/linalg/linalg.py", line 130, in _assertNonEmpty
    raise LinAlgError("Arrays cannot be empty")
LinAlgError: Arrays cannot be empty

This is probably indicative of a bug; if not, diffim should probably catch the numpy exception and either deal with it or add a more context-specific message.

See /home/rplante/dc3pipe-exec/root/rlp1151/IPSD/work/Slice5.log for more details

Change History

comment:1 Changed 10 years ago by ktl

  • Component changed from unknown to ip_diffim

Either no spatial cells are getting generated or they are all unusable. Nothing looks particularly egregious about the science image or the template for this exposure (v705308-e0-c000-a05).

comment:2 Changed 10 years ago by ktl

Can't get this one to fail on its own.

comment:3 Changed 10 years ago by rhl

  • Version Number set to ip_diffim svn8972
  • Status changed from new to assigned
  • How to repeat modified (diff)
  • Owner changed from becker to rhl

comment:4 Changed 10 years ago by rhl

  • Version Number changed from ip_diffim svn8972 to ip_diffim 3.3.8
  • Status changed from assigned to closed
  • Resolution set to suspended

I cannot reproduce this one, but the test case has a very bad astrometric solution. KT: did you check that fail.py actually failed, and, if so, with which version of ip_diffim?

I'm suspending this ticket pending a rerun using the new template-based astrometric index files.

comment:5 Changed 7 years ago by robyn

  • Milestone DC3a Completed deleted

Milestone DC3a Completed deleted

Note: See TracTickets for help on using tickets.