Ticket #775 (closed defect: suspended)

Opened 10 years ago

Last modified 7 years ago

diffim spatialKernelFit.py: index error

Reported by: RayPlante Owned by: rhl
Priority: normal Milestone:
Component: ip_diffim Keywords:
Cc: dubcovsky, ktl Blocked By:
Blocking: Project: LSST
Version Number: ip_diffim svn8972
How to repeat:

At NCSA:

cd /lsst/DC3root/ticketFiles/775
python
>>> import fail

Description

The IPSD pipeline occasionally fails in stage 34 with the following exception:

  File "/lsst/DC3/stacks/gcc412/24apr/Linux64/ip_diffim/3.3.8/python/lsst/ip/dif
fim/spatialKernelFit.py", line 318, in spatialModelByPca
    coeffs = eCoeffs[:,nc]
IndexError: invalid index

This line probably needs to look like this:

    coeffs = eCoeffs[:nc]

Change History

comment:1 Changed 10 years ago by RayPlante

see /home/rplante/dc3pipe-exec/root/rlp1151/IPSD/work/Slice5.log for more details.

comment:2 Changed 10 years ago by ktl

No, eCoeffs is supposed to be a 2-D numpy array, and this statement has the correct syntax to extract a vector from that array. Something looks fishy with the eigenvalues/eigenvectors. Turning on tracing at level 5 for lsst.ip.diffim.runPca might help.

comment:3 Changed 10 years ago by RayPlante

Do you know if one needs to rebuild (with a different LSST_MAX_TRACE) to get the desired messages, or can one simply change the runtime threshold?

comment:4 Changed 10 years ago by ktl

This is in Python using lsst.pex.logging.Trace, so changing the runtime threshold should be adequate.

comment:5 follow-up: ↓ 6 Changed 10 years ago by ktl

  • Component changed from unknown to ip_diffim

Nothing looks too egregious about the image or template for this visit (v705310-e0-c000-a05). Note that this region of sky is nearly the same as that causing problems in #776.

comment:6 in reply to: ↑ 5 Changed 10 years ago by ktl

Replying to ktl: Exposure v705197-e0-c000-a05 appears to be the first to have this problem.

comment:7 Changed 10 years ago by ktl

I can get v705310 to fail -- in a different way ("inversion of matrix fails") -- but not v705197.

comment:8 Changed 10 years ago by rhl

  • Version Number set to ip_diffim svn8972
  • Status changed from new to assigned
  • How to repeat modified (diff)
  • Owner changed from becker to rhl

The how-to-repeat fails.

comment:9 Changed 10 years ago by rhl

  • Status changed from assigned to closed
  • Resolution set to suspended

The problem is a very bad astrometric solution; the easiest way to see this is (in the how-to-repeat case):

>>> import lsst.ip.diffim.diffimStages; lsst.ip.diffim.diffimStages.display=True
>>> import fail

I'm suspending this ticket pending a rerun using the new template-based astrometric index files.

comment:10 Changed 7 years ago by robyn

  • Milestone DC3a Completed deleted

Milestone DC3a Completed deleted

Note: See TracTickets for help on using tickets.