Ticket #565 (closed defect: duplicate)

Opened 10 years ago

Last modified 7 years ago

setup often sets up the wrong package due to over-zealous implementation of ">="

Reported by: rowen Owned by: rhl
Priority: normal Milestone:
Component: eups Keywords:
Cc: ktl Blocked By:
Blocking: Project: LSST
Version Number: 1.1.0
How to repeat:

not applicable

Description (last modified by rowen) (diff)

While trying to work with svn trunk and tickets of packages I have repeatedly run into a problem where "setup" sets up the wrong pacakge. Worse, it does this silently; I want a WARNING if it's going to ignore my explicitly marked current versions.

Here is one example. I found this very confusing because most of my packages correctly use utils ticket 548 (which is more recent than svn6609), but pex_policy mysteriously did not. eups setup -v showed the problem:

setup -v pex_policy
Setting up: pex_policy                      Flavor: DarwinX86  Version: svn9999
Setting up: |boost                          Flavor: DarwinX86  Version: 1.36.0
Setting up: | python                        Flavor: DarwinX86  Version: 2.5.2
Setting up: |pex_exceptions                 Flavor: DarwinX86  Version: svn9999
Setting up: | utils                         Flavor: DarwinX86  Version: 548
Setting up: | |base                         Flavor: DarwinX86  Version: svn9999
Setting up: | |swig                         Flavor: DarwinX86  Version: 1.3.36+2
Setting up: | |doxygen                      Flavor: DarwinX86  Version: 1.5.4
Setting up: |daf_base                       Flavor: DarwinX86  Version: svn9999
Using utils version svn9999 to satisfy ">= svn6609" (548 is current)
Setting up: | utils                         Flavor: DarwinX86  Version: svn9999
              utils 548 is setup, and you are now setting up svn9999
Setting up: | |base                         Flavor: DarwinX86  Version: svn9999
Setting up: | | scons                       Flavor: DarwinX86  Version: 3.2
Setting up: | | |sconsUtils                 Flavor: DarwinX86  Version: 3.2
Setting up: | | |sconsDistrib               Flavor: DarwinX86  Version: 0.98.5
Setting up: | | | python                    Flavor: DarwinX86  Version: 2.5.2
Setting up: | |boost                        Flavor: DarwinX86  Version: 1.36.0
Setting up: | |swig                         Flavor: DarwinX86  Version: 1.3.36+2
Setting up: | |doxygen                      Flavor: DarwinX86  Version: 1.5.4
Setting up: | pex_exceptions                Flavor: DarwinX86  Version: svn9999

The problem just mentioned I consider quite serious since the obvious version number for a ticket is the number of the ticket. Note: for utils I 548 I actually did an "scons install" (something I almost never do for svn packages). I do not want to have to lie about the version number or hack up ups tables.

The problem is also an annoyance in other ways; I had been naming my svn trunk packages 999 so I could readily spot them, but that was failing the >= svn... tests so I renamed them all to svn9999 -- a bit ugly and incorrect, but at least that worked.

I would like to see the system be less clever and set up the current versions unless it has a really good reason to know it needs something else. (Or clever enough to do the right thing automatically.)

Change History

comment:1 Changed 10 years ago by ktl

Patience... I believe/hope the new versioning/comparison/tagging system will solve a lot of these woes.

comment:2 Changed 10 years ago by RayPlante

This may be a duplicate with #560 (which I created yesterday) but I'll leave that to rhl to decide.

comment:3 Changed 10 years ago by rowen

  • Description modified (diff)

comment:4 Changed 10 years ago by rhl

  • Status changed from new to closed
  • Resolution set to duplicate

This is the same as #560

comment:5 Changed 7 years ago by robyn

  • Milestone DC3a Apps Framework deleted

Milestone DC3a Apps Framework deleted

Note: See TracTickets for help on using tickets.