Ticket #433 (closed documentation: fixed)

Opened 11 years ago

Last modified 7 years ago

Generate doxygen documentation as part of buildbot

Reported by: rhl Owned by: bbaker
Priority: normal Milestone:
Component: doxygen Keywords:
Cc: Blocked By:
Blocking: Project: LSST
Version Number:
How to repeat:

not applicable

Description

All LSST packages are expected to generate doxygen documentation, but this is not made available on trac. As the buildbot is already generating this documentation, we should arrange to link it into trac.

Change History

comment:1 Changed 11 years ago by bbaker

  • Status changed from new to assigned

comment:2 Changed 11 years ago by bbaker

  • Status changed from assigned to closed
  • Resolution set to fixed

Finished. See http://dev.lsstcorp.org/doxygen. Automatically updates trunk and new released versions during nightly build.

comment:3 Changed 11 years ago by rhl

  • Status changed from closed to new
  • Resolution fixed deleted

The URL http://dev.lsstcorp.org/doxygen doesn't work; is there a typo?

comment:4 Changed 11 years ago by bbaker

  • Status changed from new to closed
  • Resolution set to fixed

Oops. Need a trailing slash.

http://dev.lsstcorp.org/doxygen/

comment:5 Changed 11 years ago by rhl

  • Status changed from closed to new
  • Resolution fixed deleted

The page http://dev.lsstcorp.org/doxygen/release/ doesn't seem to have updated since 2008-11-13; isn't it supposed to update every night?

comment:6 Changed 11 years ago by bbaker

Released packages: The nightly build only overwrites documentation for new versions, by design, at Ray's request. Once we get a successful nightly build, we should see the new versions alongside the old ones (afw 3.2, for example).

Trunk: Updated whenever a package build succeeds (ideally nightly).

comment:7 Changed 11 years ago by bbaker

  • Status changed from new to assigned

The nightly build *isn't* actually copying new released versions' docs -- I left some code in a test script and forgot to move it into the production script. Should be fixed now -- test running, will know if it's working in a couple of hours, when the build finishes.

comment:8 Changed 11 years ago by bbaker

  • Status changed from assigned to closed
  • Resolution set to fixed

Confirmed working -- see http://dev.lsstcorp.org/doxygen/release/utils/ for example.

comment:9 Changed 7 years ago by robyn

  • Milestone DC3 Infrastructure Prep deleted

Milestone DC3 Infrastructure Prep deleted

Note: See TracTickets for help on using tickets.