Ticket #2703 (closed defect: worksforme)

Opened 7 years ago

Last modified 6 years ago

can't find calibRegistry when input directory has a _parent link

Reported by: jbosch Owned by: jbosch
Priority: minor Milestone:
Component: daf_butlerUtils Keywords:
Cc: ktl Blocked By:
Blocking: Project: HSC
Version Number:
How to repeat:

not applicable

Description

I believe that calibration registries are usually at <raw>/CALIB/calibRegistry.sqlite, where <raw> is the root of the data repository that holds the raw data i.e. the one that doesn't have a parent link (or at least that's where they are for Subaru). CameraMapper seems to be able to find this just fine as long as the "root" passed to the constructor is "<raw>", but it fails when "root" has a _parent link to "<raw>".

Easy workaround is to use --calib, and even that's only necessary when you're running with <raw> different from "root", so this is not as urgent as it might otherwise be; just wanted to mark it as a known bug.

Change History

comment:1 Changed 7 years ago by jbosch

  • Owner changed from ktl to jbosch
  • Status changed from new to needInfo

Weird...apparently this problem doesn't always occur under the conditions described above. I'll have to investigate further.

comment:2 Changed 6 years ago by jbosch

  • Status changed from needInfo to closed
  • Resolution set to worksforme

Can't reproduce anymore. May have just been user error originally.

Note: See TracTickets for help on using tickets.