Ticket #1967 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

pex::logging's debug messages don't handle varargs messages

Reported by: rhl Owned by: rhl
Priority: normal Milestone:
Component: pex_logging Keywords:
Cc: Blocked By:
Blocking: Project: LSST
Version Number: 4.8.0.2
How to repeat:

Run examples/debug

Description

If I run examples/debug I see:

 myapp DEBUG: I'm starting this routine
   myapp DEBUG: Starting iteration #1769461792
  myapp DEBUG: starting iterations
  myapp.func DEBUG: calling the function: 

The #1769461792 line is:

dblog.debug<3>("Starting iteration #%i", 100);

The problem is that debug calls format (with a final ... argument) not _format (with a va_list).

I'll commit a fix as soon as this ticket is safely filed

Change History

comment:1 Changed 7 years ago by rhl

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in r928cd9088

Note: See TracTickets for help on using tickets.