Ticket #1555 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

'coadd_utils/tests' require afwdata setup, although spec'ed optional in coadd_utils.table

Reported by: robyn Owned by: rowen
Priority: normal Milestone:
Component: coadd_utils Keywords:
Cc: rowen Blocked By:
Blocking: Project: LSST
Version Number:
How to repeat:

Build coadd_utils without afwdata setup

Description

coadd_utils fails in tests/warp.py:

cat tests/.tests/warp.py.failed
      > tests/warp.py
      > 
      > Traceback (most recent call last):
      >   File "tests/warp.py", line 44, in <module>
      >     raise RuntimeError("Must set up afwdata to run these tests")
      > RuntimeError: Must set up afwdata to run these tests

ups/coadd_utils.table indicates: "setupOptional(afwdata)"

warp.py includes the test:

dataDir = eups.productDir("afwdata")
if not dataDir:
    raise RuntimeError("Must set up afwdata to run these tests")

'SConscript' already notifies the users that if 'afwdata' is not available, tests requiring 'afedata' will not be run. So this hard error in 'warp.py' should become a WARNING that a test was not run.

Change History

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc rowen added

comment:2 Changed 9 years ago by rowen

  • Status changed from new to assigned

comment:3 Changed 9 years ago by rowen

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixed in svn rev18879

Note: See TracTickets for help on using tickets.